Fly Launch is giving a different output than usual


I’m confused by the output prompts I’ve been getting when running Fly Launch. Usually I expect to give a name, choose a region, cpu size, postgres, etc. However, when running Fly Launch with a Dockerfile and prod.conf file in a directory, I’ve been given this instead.

Scanning source code
Detected a Dockerfile app
Creating app in /home/stefannovak/Projects/Personal/Medium/rabbit
We're about to launch your app on Here's what you're getting:

Organization: Stefan Novak           (fly launch defaults to the personal org)
Name:         patient-frost-2393     (derived from your directory name)
Region:       London, United Kingdom (this is the fastest region for you)
App Machines: shared-cpu-1x, 1GB RAM (most apps need about 1GB of RAM)
Postgres:     <none>                 (not requested)
Redis:        <none>                 (not requested)

? Do you want to tweak these settings before proceeding? (y/N) 

Selecting Yes takes me to a nice new web page I’ve not seen before. I wouldn’t have a problem with it all except that I can’t stop this from automatically deploying which is not what I want. I want to modify the fly.toml file first.

Did something change?


1 Like

Hi! fly launch got rewritten as of flyctl v0.1.123. The announcement should be posted here soon (I totally meant to get that out before flyctl shipped)

We tried to get rid of the massive wall of questions that launch used to ask, so some things that are less common got moved to CLI flags. You’re looking for the --no-deploy flag.


Awesome thanks Allison! I thought it might be that haha, I was looking for an announcement.

Great job it looks good!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.