Fly deploy fails with no disks available

what is going on here?
can I change region for builder if there is issue with otp? I’ve tried fly regions add, but each deployment ends with error with otp builder

$ fly deploy
==> Verifying app config
--> Verified app config
==> Building image
WARN Failed to start remote builder heartbeat: Couldn't allocate volume, no disks available (region: otp, size_gb: 50)
Error failed to fetch an image or build from source: error connecting to docker: Couldn't allocate volume, no disks available (region: otp, size_gb: 50)

try using the local docker builder (docker desktop must be running) till remote builder is fixed

flyctl deploy --local-only

yes, local build moves me to next step, image is now built and pushed into fly registry and relase is created. However now it is stuck at:

==> Creating release
--> release v2 created

--> You can detach the terminal anytime without stopping the deployment
==> Monitoring deployment

v0 is being deployed

at the same time Fly dashboard keeps app in pending state and a mesage

A new version of your app is being deployed!

monitoring the deployment yields:

Waiting for logs…

I must conclude that not only builders are having trouble, but deployment too

I moved to different region (from otp) and managed to deploy.
It works now, probably otp is useless at the moment

Could you let me know who you managed to change the region away from otp?
I tried setting a new region, adding new regions, removing otp from supported regions but nothing worked and it still tries to deploy to otp.

I selected region fra during

fly launch

and did not run deployment

then I checked with command

fly regions list

and noticed I am in fra

but command

fly deploy

tries to use otp as builder anyway. I avoided that remote builder with advice from @thanasisxan

fly deploy --local-only

so build runs locally, deployment outside of otp

Same problem here.
Also have fra on my regions.
Also tries to deploy to otp.