Fly deploy failing executing release command

Hello, I hope you are well

A few hours ago I have been trying to deploy my application. I only just realized that this had not been happening.

I had 4 GitHub Actions running hours ago because of this problem. It would be great if you could add some timeout, because if I hadn’t noticed it would have used up my available minutes.

What happens is that it keeps running the release command and never finishes. I haven’t made any changes there that would cause something like that to happen. It doesn’t even give an error, it just waits.

I have not been able to deploy because of this.

What can I do? I don’t think it’s a problem on my end.


So far, deploys remain very itermittent. One was recently successfully executed. Now I have a new one, and it ran the release command, but it gets stuck in the deploy.

It only shows v79 is being deployed.

It doesn’t even report if the checks pass or not.

I have already tried 4 times with the same result.

Now that I know about this problem, I manually stopped the GitHub action, but it’s still a risk anyway.

In the monitoring section of the dashboard, it says this:

“Deploying v80
Deployment is running pending automatic promotion.
2 desired, 0 placed, 0 healthy, 0 unhealthy”

Minutes ago. No progress

There should really be 6 healthchecks

It was finally deployed a few hours later.

It would be great if more information could be provided in this process. I never really knew what happened, and as I was telling you that could consume many minutes of GitHub actions.

I’ll be testing how it behaves the next few times and I’ll report back here.

Please, if you could help me I would appreciate it.