Fly API error on deploy

Trying to push a fix for a customer and consistently hitting this:

0c78fac124da: Layer already exists 
deployment-01GD0PEEWG9589BVZAX64T6959: digest: sha256:16e7a683bfaef717945d6cd04d78091a90ef047b3ef7924022a3bb5149c1deb3 size: 6166
--> Pushing image done
==> Creating release
Error You hit a Fly API error with request ID: 01GD0PEM4K8348QFSQ4P9WX0QG-ams

Tried switching the specific version of container image I was pushing but that did nothing.

Updated my fly client and I’m currently running it like this:

fly deploy --local-only -c infrastructure/fly.tww.toml -i[redacted]staging-rc1-cb0658aa1416b8701c8b9476f3d4da668575e6f8-5a9121a66

The API error isn’t very good here :confused:

I just looked at the actual exception and it seems your concurrency settings are in the wrong format. Could you share your fly.toml or retry with a properly formatted [services.concurrency] section?

That explains it.

We had pushed new concurrency settings but they didn’t seem to take. So I tried adding more brackets because other sections had more brackets. My bad on that.

With a restart just now the new concurrency settings took.
That error was not ideal, no :confused:
Could only assume there was a service error or something.

@jerome can you see why we managed to deploy a new config for concurrency (we could see it had been received with fly display…) but it didn’t take until I just now restarted the app? I’d have expected that deploy to have triggered the redeploy and as such restarted things?

We’ve noticed this bug recently and have been working on a solution. No ETA yet, but for now a “full” deploy or restart is unfortunately required.

The technical details: this changes some meta data without triggering a full deploy and our proxy isn’t properly taking the new limit into account.

Thanks. That takes care of the mystery for is.