Failed due to unhealthy allocations (?)

What does this error message mean? I’m trying to deploy a dockerfile, nothing in the “INFO” logs indicate any errors.

After searching the forums people seem to say it has an issue relating to ports, I have internal and exernal ports defined in my fly.toml

app = "fastsocks5"

  internal_port = 1080
  protocol = "tcp"

    hard_limit = 2048
    soft_limit = 1024

    handlers = []
    port = 1080

Why is this error message so vague? I feel like it could be improved.

What’s more frustrating is that this reply says that Dockerfile EXPOSE doesn’t affect anything

But then the Fly io troubleshooting docs themselves say to “make sure you have an EXPOSE port in there” (I get the same error whether I omit it or not)

After a lot of fiddling around, i’ve found that it was apparently the way I called CMD in my Dockerfile, I was not executing bash in the arguments to CMD

This worked fine:

CMD /bin/bash -c '/usr/local/bin/server -l; /bin/bash'

1 Like

This error will improve in the next couple of months. It comes from Nomad, which we’re replacing. One reason we’re replacing it is: errors are pretty opaque and it’s hard for us to tell you specifically what went wrong.

I’m glad you figured it out! I just wanted you to know you’re not the only person who hates that error. :wink:

1 Like