Failed due to unhealthy allocation with no web server

I’ve read the docs and half the similar community posts but still confused… my app is a simple mastodon bot GitHub - yuletide/nitterbot nitterbot ( -

It’s a very basic python app built with poetry. Unlike my very easy deploy on Railway, fly failed to detect an app with fly launch so I had to go learn docker to get things running (the things. I do for a better free tier…).

I re-ran fly launch and got things running with this fly.toml

# fly.toml file generated for nitterbot on 2022-12-23T23:31:36-05:00

app = "nitterbot"
kill_signal = "SIGINT"
kill_timeout = 5
processes = []


  allowed_public_ports = []
  auto_rollback = true

  http_checks = []
  internal_port = 8080
  processes = ["app"]
  protocol = "tcp"
  script_checks = []
    hard_limit = 25
    soft_limit = 20
    type = "connections"

    force_https = true
    handlers = ["http"]
    port = 80

    handlers = ["tls", "http"]
    port = 443

    grace_period = "1s"
    interval = "15s"
    restart_limit = 0
    timeout = "2s"

I imagine this has something to do with exposing or listening on ports for a health check, but this app does not run a web server or accept any incoming connections other than the mastodon streaming api connection. Is there something else I should be configuring here?

I also tried running flyctl checks list (returns empty) and removing the TCP checks from this config and deploy again but same result.

Ok thanks to feedback from a friend I tried just removing the entire services section entirely and that seemed to work. Might be worth adding more to the docs around this stuff, especially since it’s autogenerated…