Error Post "": unexpected EOF

When running fly deploy I get this unexpected EOF. Using --verbose doesn’t shed any more light. I’ve also tried deleting everything and restarting, same results. Any help? I see others have seen this error when’s infrastructure down but the status page shows all green.

image size: 1.0 GB
==> Creating release
Error Post "": unexpected EOF

Edit: When I have a release_command it runs, but then the main program never starts, it ends with:

 2022-07-16T11:57:31.159 app[946846f1] ord [info] No migrations to apply.
2022-07-16T11:57:31.620 app[946846f1] ord [info] Main child exited normally with code: 0
2022-07-16T11:57:31.620 app[946846f1] ord [info] Starting clean up. 

I think this may be an indication that it is an error with the Dockerfile.

Strange. Are you able to post the Dockerfile to see if anyone can spot an issue with it? I’m not sure that is the issue here though. Given that shortened output, it reads like it was able to build an image using that Dockerfile. But failed at the subsequent step, releasing it. Hmm.

Do you get that EOF intermittently or consistently?

Out of interest, what do you see when you visit the Fly debug page? If you are able to see all the debug headers etc that would show at least that part of the networking from your location is fine (it will respond from the closest region):

I’m hitting the same issue when deploying through Github Actions:

979117655379: Layer already exists
92a02f6117f5: Layer already exists
deployment-1658158818: digest: sha256:524d2db890c5990cf6ca4845f809128b0b88d5eb25b1842e0f553fc644cfdf84 size: 3263
--> Pushing image done
image size: 963 MB
==> Creating release
Error Post "": unexpected EOF
Error: Process completed with exit code 1.

This started a few days ago and was only resolved by deleting the app and recreating it.

Seems like Fly had some issues since other people reported issues too related to the API/releasing:

Sounds like they’ve sorted them.

In the end the only thing that fixed it was remaking the docker file and config file, delete all the apps and relaunch.