ERROR: No matching distribution found for apsw

Hi there,

I have tried to deploy my Python app (following instructions here Build, Deploy And Run A Python Application · Fly Docs and in the command line after “launch”), but I get the following error:

 => ERROR [6/8] RUN pip install -r requirements.txt                                            3.7s
 > [6/8] RUN pip install -r requirements.txt:                                                       
#8 3.073 Collecting absl-py==1.0.0                                                                  
#8 3.124   Downloading absl_py-1.0.0-py3-none-any.whl (126 kB)                                      
#8 3.154      ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 126.7/126.7 KB 7.0 MB/s eta 0:00:00           
#8 3.221 Collecting anyio==3.5.0                                                                    
#8 3.228   Downloading anyio-3.5.0-py3-none-any.whl (79 kB)
#8 3.234      ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 79.2/79.2 KB 22.3 MB/s eta 0:00:00
#8 3.275 ERROR: Could not find a version that satisfies the requirement apsw==3.34.0.post1 (from versions: 3.8.2.post1, 3.8.5.post1, 3.8.6.post1,,,,,, 3.8.9.post1,,, 3.9.2.post1, 3.36.0.post1, 3.38.5.post1)
#8 3.276 ERROR: No matching distribution found for apsw==3.34.0.post1
#8 3.416 WARNING: You are using pip version 22.0.4; however, version 22.1.2 is available.
#8 3.416 You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Error failed to fetch an image or build from source: error building: executor failed running [/bin/sh -c pip install -r requirements.txt]: exit code: 1

Any ideas?

Cheers, Manuel

It seems that maybe that version of apsw listed in your requirements.txt is no longer available or another package is required that obsolete version. Are you able to pip install that package locally ?