Error: failed to fetch an image or build from source: executing lifecycle: failed with status code: 62

Hi, it is my first attempt at deploying to

I got the following error, would be grateful for some advice?

Here is my deploy log build -

Hey there,

I see you are trying to deploy your app and are receiving errors in regards to your builder setup or configuration. Would you mind posting your fly.toml file (just don’t include .envs) if one was created?

Here it is:

app = “floxai”
primary_region = “lhr”

builder = “paketobuildpacks/builder:base”

PORT = “8080”

internal_port = 8080
force_https = true
auto_stop_machines = true
auto_start_machines = true
min_machines_running = 0
processes = [“app”]

There’s a few things I’d like to digest:

  1. I’m not sure if you are aware of this or not, but the repo for paketo-base-builder has been archived: GitHub - paketo-buildpacks/base-builder. They are moving forward with this instead- GitHub - paketo-buildpacks/builder-jammy-base: A Cloud Native Buildpacks (CNB) builder with the Paketo Jammy Jellyfish Base stack and Paketo buildpacks..
  2. I’m by no means an expert with Docker or it’s image layer system but the link you attached that shows the logs looks to indicate that there is an issue fetching the base image layers, and it might be caused by some corruption or missing files in the Docker overlay2 storage. You could try to:
  • Clear Docker Cache: Clearing the Docker cache may help in cases of corruption. I would take a look at this article- Docker Overlay2 Cleanup.

  • Restart Docker: Sometimes, issues like this can be resolved by simply restarting the Docker daemon. Restart Docker and try building and deploying the app again.

Here is the documentation for dockers overlay 2 storage- Use the OverlayFS storage driver | Docker Documentation

Thank you very much for the suggestions.

The the fly.toml file was auto generated for me using the fly cli: fly deploy. I am not interacting or building docker images at all, on my local side.

Is there a way I can try restarting docker or clearing cache on (if that is what you meant for me to try)?

I’ve modified my toml file and replaced the builder with:

 builder = "paketobuildpacks/builder-jammy-base"

I tried deploying like that, but this failed with the same error code :frowning:

Thanks again.

Hey @antoan - are you running GitHub - Chainlit/chainlit: Build Python LLM apps in minutes ⚡️?

Could you share some of the details for getting your project setup?

Hoping to better understand how standard (or not) your project is!

One more question; do you have a requirements.txt in your project directory? I noticed their docs don’t really call out any of the ways that file usually gets written.

Sort of separately from getting you unblocked here; once you share some more details about your project, we might be able to get a basic Dockerfile together for your project. Buildpacks are notoriously large, slow, and less predictable than a Dockerfile that’s more specific to your needs.

Hi @jphenow,

I am not using that particular project although I do have a chainlit app, here is my code:

I do have a requirements.txt.

Some help with a dockerfile would be much appreciated.

Thank you.

Strangely I was able to get an image at least built and pushed.

It was rather large at about 5.1GB and failed to boot.

Out of curiosity - I wonder if we reset your builder and tried again if we’d get any better results.

If you go to the dashboard, delete the builder app, and try deploying again do you get different results?

I can describe that in more detail if it’s confusing!

1 Like

I face the same issue with python when I try to deploy an app where I load load a 250Mb model

Repo link: GitHub - datduyng/fly-python-torch-issue

Hey could you try scaling your machine’s memory and let us know if that helps?

You can view your current settings with fly scale show

My machine isn’t active so I couldn’t scale. fly scale show show me empty response

I tried to put my python code in a docker container but I faced “2GB docker image limit” issue. I assume this might be the root cause?

Ah my mistake, you can also specify it on your deploy like so: fly deploy --vm-memory 2048

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.