error connecting to docker

I’ve started seeing this error when I run flyctl deploy --remote-only:

==> Verifying app config
→ Verified app config
==> Building image

Error failed to fetch an image or build from source: error connecting to docker: You ran into an error connecting to the Fly API. If the error persists, keep this request ID to help Fly Support track it down: 01G894HJQWX3C93KRHATBYXA2M-lga

I have tried deleting my builder and letting it recreate a few times, hasn’t helped.

Any ideas? Thanks!



I’m seeing this as well on one of my apps.

1 Like

would you mind posting your request ID in the error message you got as well? this will help us pinpoint any issues more readily, as this error message can happen for a quite a number of different reasons.

Me too! I thought this my network issue so I switch to local Docker daemon.

do you still have the request ID from when you were experiencing this, and
did switching to the local docker daemon resolve your deployment issue?

I am running deploy via Github Action. Here is the request ID from the latest attempt:

1 Like

Getting the same error- here’s my request ID: 01G89674D5MF14AXGQ74K5MRED-lga

1 Like

Local Docker works, but not the remote one, I guess there’s some outage on’s end

1 Like

hey all, I just wanted to let you know that we were able to trace these request IDs to changes that we made today that were causing issues with the remote builders.

We’re working on rolling out a fix right now.

1 Like


the fix has been completely rolled out, so remote building should be working normally now–please let us know if you’re still running into this error message, alongside the request ID you’re getting. thank you all for supplying that info earlier!


Can confirm it works now, thanks a ton!


Working for me now too, thanks