Documentation heavily outdated for Volumes

Hi guys, the documentation for the Volumes page is heavily outdated. It makes it very hard to onboard and follow along.

  1. It says, check if your org is v2 by running this command: fly orgs apps-v2 show <org-slug> then when I run it it gives an error saying that the fly orgs command does not expect that many arguments (??)
  2. The following command creates a new volume named “myapp_data” with 40GB of storage in the lhr (London Heathrow) region, for the application whose fly.toml file is in the working directory. To specify a different app, use the -a or --app flag. But when you look at the example given, it’s not in LHR and it’s not 40gb (??)
  3. There is no explanation for how to set Attached_VM to the volume, or what it is used for.
    I created a volume with the instrucitons and the create command and the ATTACHED_VM column is empty when I run fly volumes list
  4. There is no suggestions/tips for how to actually USE this volume…
    My problem is that I want some persistent storage between my fly app deployments. So I thought let’s use a volume to essentially store that on disk and not be susceptible to fly deployments and vm refreshes.
    I am still in square 1 because the documentation is not helping me set this up.

Any help to my actual problem is appreciated it but more importantly, on an acknowledgment to fix the documentation

Is for the ATTACHED_VM part…
backend_volume is the name of my volume.
Not marking this as resolved as the documentatio nis heavly outdated and an ack from fly team would be great.
@rubys cc

docs are here: App Configuration (fly.toml) · Fly Docs

Thanks, maybe combine with: Volumes · Fly Docs ?
As a user, I don’t know which is the most up to date doc or not, I just consume whatever you folks put up in your site.
The doc I linked to is outdated/does not have all the pointers.

It sounds like your flyctl might be out of date. Can you try upgrading to the latest version, v0.0.524?

We’ve fixed this one. Thanks for reporting!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.