Deploys never get past build stage

Hi all,

Got a fairly urgent issue right now and I’m not sure how to debug what’s happening.

Here’s what’s happened so far:

  • yesterday evening (GMT) I deployed a new version of my app, the build went well and I can see the new release registered in the dashboard
  • a VM running the new release is never created - no feedback as to why
  • check again this morning to see if it was a long delay problem but nothing’s changed
  • Scale the app down to 0 and back to 1 to attempt to kick-start a fresh VM
  • My app is now offline and I’m at a loss on where to go from here

The last logs I’ve got are

2023-03-21T08:48:38.369 app[bb69c3fd] lhr [info] HEAD / 200 - - 3.622 ms
2023-03-21T08:48:38.370 app[bb69c3fd] lhr [info] GET /healthcheck 200 - - 6.546 ms
2023-03-21T08:48:48.378 app[bb69c3fd] lhr [info] HEAD / 200 - - 3.857 ms
2023-03-21T08:48:48.379 app[bb69c3fd] lhr [info] GET /healthcheck 200 - - 6.899 ms
2023-03-21T08:49:11.481 runner[bb69c3fd] lhr [info] Shutting down virtual machine
2023-03-21T08:49:11.686 app[bb69c3fd] lhr [info] Sending signal SIGINT to main child process w/ PID 528

Here’s what’s happening with the VM

➜  fly vm status bb69c3fd
Update available 0.0.470 -> 0.0.495.
Run "fly version update" to upgrade.
  ID            = bb69c3fd              
  Process       = app                   
  Version       = 49                    
  Region        = lhr                   
  Desired       = stop                  
  Status        = complete              
  Health Checks = 2 total, 2 passing    
  Restarts      = 0                     
  Created       = 2023-01-17T15:21:36Z  

TIMESTAMP               TYPE            MESSAGE                                         
2023-01-17T15:21:13Z    Received        Task received by client                        
2023-01-17T15:21:13Z    Task Setup      Building Task Directory                        
2023-01-17T15:26:13Z    Alloc Unhealthy Task not running by deadline                   
2023-01-17T15:26:41Z    Started         Task started by client                         
2023-03-21T08:48:56Z    Killing         Sent interrupt. Waiting 5s before force killing
2023-03-21T08:49:21Z    Terminated      Exit Code: 0                                   
2023-03-21T08:49:21Z    Killed          Task successfully killed                       

ID                                      SERVICE         STATE   OUTPUT                                                            
03833b6def760b24d9962af66e7ec077        tcp-8080        passing HTTP GET 200 OK Output: OK
3df2415693844068640885b45074b954        tcp-8080        passing TCP connect Success                          

Recent Logs

Is there anything I can try here?

Sometimes deploys just fail and we’re working hard to make the experience better.
Can you try deploying a new version of your app?

1 Like

Hey griff, thanks for replying!

I thought it might be that, so that’s why I waited overnight. I think I’ve tried about seven or eight times now in various forms.

I’ve been referencing this discussion and my journey roughly follows what they experienced. Destroying VMs and trying to force the creation of machines on deploy hasn’t worked either.

I’m now falling back to the idea that something is broken with v1 apps. I’ve recreated the whole app so it starts with v2 and I’m stepping through that now…

I had to recreate the whole app from scratch to get anywhere.