Deployment running for several minutes

Deploying via Github Actions and this here is the status of my deployment for more than 5 minutes now. Normally it takes a few seconds (it’s only one vm).


Didn’t change anything in the deployment pipeline, does someone have the same issue? If it’s only temporary and not under my control, it would be good to know.

EDIT: same thing happens when I try to deploy via flyctl from my own machine:

--> release v32 created

--> You can detach the terminal anytime without stopping the deployment
==> Monitoring deployment

v32 is being deployed

Seeing the above for more than 10 minutes now.

Just tried a new release on a different fly-app. That worked. I don’t know what was messed up cause I didn’t change much, especially nothing in the deploy pipeline.

Restarting the app or scaling to 0 and back to 1 didn’t work at all. Now the app is offline + can’t be redeployed. Worst case I have to delete the whole app and setup a new, identical app.

After 2 hours of non-deploy and ~20min downtime, I am going to just destroy the app and recreate an identical one.

This sounds like it might be doing a canary deploy when it shouldn’t be.

If you are using volumes, or you ran fly scale count 1 --max-per-region=1, you’ll need to use a rolling deploy. fly deploy --strategy rolling might help.

Experiencing the same issue here even with --strategy rolling. Our app uses volumes, so I assume this would have been the default.

What changed?

I didn’t explicitly try to change the strategy to rolling. I think this was the default for me too. I didn’t change anything, so if it was on canary it would have failed before too.

The recreation worked fine, I just had to recreate secrets and volume again, not sure if I could have somehow transferred the volume, but it wasn’t so important in my case.