Deploy is successful but the page is just loading

Hello, i have been following a Udemy course so all of this is pretty new to me, so i am struggeling to troubleshoot what i have done wrong. I have a docker image and tried to deploy with, which is successfull, but the link is not working. Could anyone please review my screenshots and provide me with some tips? Appreciate it!! <3 <3
Running command “fly deploy” -

Running command log:

Image of my fly.toml file:

I created it with a db, as the teacher did in the course as well, but thats the only thing that is “green” :

Hi @annadev2001 ,

It is always a good time to start :slight_smile:

First let’s check what name has the application that you have deployed, for it we can do it with this instruction:

$ fly apps list

Then we can see the logs that our application has generated, for this we can do it with the following command:

$ flyctl logs -a [your-app-name]

Here you can see what is happening.

Let me know how it goes,
Sergio Turpín

1 Like

Hi @sturpin :blush: Thank you for fast reply!
Here is the new screenshots!
$ fly apps list

$flyctl logs -a reactivities-annadev2001:

What docker image are you using for your application and what internal port do you have configured?

Sergio Turpín

1 Like

Using docker desktop(?)
Also configured in terminal by running:
$ docker build -t annadev2001/reactivities
$ docker run --rm -it -p 8080:8080 annadev2001/reactivities
And this workes fine, so if i run the docker, and go to localhost:8080 my application is working, so i assume the problem has to be with the

This container is for Postgres which exposes its port 5432, I would like to see the one you show in your app.

Show me your hostname
$ flyctl status --verbose

Show me also this output
$ flyctl status -j | grep internal_port

Sergio Turpín

1 Like

OK, now that I have tried to access, show me the logs it has generated.

Sergio Turpín

You mean to run flytcl logs -a “name” again?

Yes, please :slight_smile:

Ait mate

OK, you have some Exception in your App. You need check Program.cs on line:21 and IdentityServiceExtensions.cs file on line:25. So your container is mounted correctly, but internally your App configuration is not correct.

Sergio Turpín

Oh nooo :smiling_face_with_tear: :smiling_face_with_tear: :smiling_face_with_tear: :smiling_face_with_tear:
Thank you Sergio, ill try have a look inside App

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.