deploy / ip allocation / cannot connect to app

Hi friends,

We are deploying apps using fly CLI, to SJC. Starting getting “ip allocation errors” during deploy today. Following the instructions in the log, we use fly ip allocate-v4 -a ... --shared. The remediation worked once, but not again. Possibly the first time remediation worked due to time delay only.

Doesn’t work means the app’s host’s 443 cannot be connected to.

% curl -I

curl: (35) LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to 

Any color on this? In our automation scripts that does deploy, we may start to always run fly ip allocate-v4 following fly deploy - based on the CLI output, the command appears to be idempotent.

In any case, right now… even though fly ips list shows ipv4 and v6 entries, still cannot connect.

Wondering if other folks hitting this?

2023-07-21 15:40:27 [info     ] [RX:twitter-1689979110] Failed to provision IP addresses, use `fly ips` commands to remmediate it. ERROR: error allocating ipv6 after detecting first deploy and presence of services: server returned a non-200 status code: 504  Machine 6e82dd3b265487 [app] was created
2023-07-21 15:40:27 [info     ] [RX:twitter-1689979110] Finished launching new machines
2023-07-21 15:40:27 [info     ] Ensure that fly IP allocation is good (just allocate-v4 again... idempotent)
2023-07-21 15:40:27 [info     ] Running sys_run                cmd=fly ip allocate-v4 -a rxhtest-1689979110-twitter-1689979110 --shared cwd=None label=_system timeout=5
2023-07-21 15:40:27 [info     ] [RX:_system] VERSION    IP              TYPE    REGION
2023-07-21 15:40:27 [info     ] [RX:_system] v4  shared  global


It may be unrelated to your issue, however since you mention connecting to the app’s 443, there is a current issue related to TLS:

Thanks… you are right I think. My guess is I’m hitting two issues. The IP allocation thing is indeed fixed by doing extra fly allocate-* runs, but the 443 issue is related to the outage.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.