Cluster VM Keeps shutting down

Yesterday i deployed a laravel app on fly and it worked very well - kudos to supporting Procfiles by the way👍- . This morning i tried to deploy some changes but it seems to not work, it gives me a 500 server error on the frontend and these logs when i try flyctl logs:

2021-10-28T14:55:38.287 app[1ad0dafa] dfw [info] DOCUMENT_ROOT changed to 'public/'
2021-10-28T14:55:38.317 app[1ad0dafa] dfw [info] Detected 9223372036854771712 Bytes of RAM
2021-10-28T14:55:38.329 app[1ad0dafa] dfw [info] Limiting to 16G Bytes of RAM usage
2021-10-28T14:55:38.331 app[1ad0dafa] dfw [info] PHP memory_limit is 128M Bytes
2021-10-28T14:55:38.336 app[1ad0dafa] dfw [info] Starting php-fpm with 128 workers...
2021-10-28T14:55:38.396 app[1ad0dafa] dfw [info] Starting httpd...
2021-10-28T14:55:38.505 app[1ad0dafa] dfw [info] Application ready for connections on port 8080.
2021-10-28T14:55:50.169 proxy[1ad0dafa] dfw [warn] Health check status changed 'passing' => 'warning'
2021-10-28T14:55:58.969 proxy[1ad0dafa] dfw [info] Health check status changed 'warning' => 'passing'
2021-10-28T14:56:14.018 runner[5daa7de5] dfw [info] Shutting down virtual machine
2021-10-28T14:56:14.108 app[5daa7de5] dfw [info] Sending signal SIGINT to main child process w/ PID 510
2021-10-28T14:57:30.327 app[1ad0dafa] dfw [info] - - [28/Oct/2021:14:57:29 +0000] "GET / HTTP/1.1" 500 6615 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36

That shut down message appears to be an older version of the VM. 5daa7de5 was version 4, 1ad0dafa is version 5.

Can you enable additional logging? That 500 error is coming from the app itself, from our perspective 1ad0dafa is working as it should. If you can get an exception logged we can help figure out what’s happening.