Certificate only works on some devices

I set up an application lisudoku.fly.dev. In order to set up my custom domain I also created lisudoku-proxy.fly.dev. This is the nginx.conf:

server {
  listen 8080;
  listen [::]:8080;

  server_name api.lisudoku.xyz lisudoku-proxy.fly.dev;

  location / {
      proxy_ssl_name $http_host;
      proxy_ssl_server_name on;
      proxy_pass https://lisudoku.fly.dev;
      proxy_set_header X-Forwarded-Host $http_host;

I added a certificate to lisudoku.fly.dev.

The issue is that https://api.lisudoku.xyz works on my laptop and phone (I see the “Server is running” response), but it doesn’t seem to work anywhere else. I tried testing with browserstack and the page doesn’t load.

Any ideas? Not sure I even set it up correctly, it was all trial and error.

Ok, I think I fixed it.

When setting up the certificate, instead of following the instructions on the Certificates page and setting an AAAA record, I just set a CNAME record pointing to https://lisudoku.fly.dev/ and this seems to work. Not sure why though…

Do you have an up to date flyctl? Might’ve missed adding the A record which could be a shared IP

I installed flyctl for the first time so I imagine it was up to date. But I just followed the on-screen instructions, I didn’t find the ips from the command line.