cant install fly ctl

cant install fly ctl with this command - “curl -L | sh”, it gives me following error - curl: (3) URL using bad/illegal format or missing URL. i tried to put url in quotes.

Hi… The installer script calls curl twice more, internally, so that may be where the error is coming from…

Try the following first:

curl -L -o

If that works then:

echo "$(uname -s)/$(uname -m)/latest"
curl "$(uname -s)/$(uname -m)/latest"; echo

The above should give you a Github URL at the end. Feed that in turn to the third curl invocation:

curl -L "" -o flyctl.tar.gz

(That is the string for Linux at the moment; be sure to replace with what reported.)

My guess is that it’s the second one that is failing… If so, let us know what the immediately preceding echo gave.

Hope this helps!

Added flyctl

for the context i am using git bash on windows 10 because powershell installation also failed. when i run first command i get this url when i run following commands i get just error page html telling me that page doesnt exist, same on browser. i guess reason is MINGW64 and not being able to find version for my operating system. ubuntu link you mentioned works on browser so can i use ubuntu link ?
this is also command and error i get on powershell run as administrator:

powershell -Command "iwr -useb | iex"
iwr : The underlying connection was closed: An unexpected error occurred on a send.
At line:1 char:1
+ iwr -useb | iex
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebExc
    + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand 

i tried to resolve this http request problem but no have been able to yet.

i googled and find out that i might be able to install windows version with git bash so can you give me url for windows version

Interesting… Looking inside install.ps1, it appears that it would use plain /windows/ as the platform component:

I’ve heard mention of people successfully running flyctl within WSL2, but I don’t know which exact binary that ends up as.

(I don’t have a Windows machine myself, these days.)

That was good thinking, overall, though…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.