Can not SSH to domain <my-app> without a dedicated V4 IP

Hi everyone,

I tried to build a remote development environment on (followed this tutorial cloud development environment with Visual Studio Code Remote-SSH | Lambros Petrou and a bit of this outdated guide VS Code - Remote Server over SSH · Fly Docs)

I noticed that if I don’t allocate a dedicated V4 IP, I can not connect to the domain via SSH (or VS code Remote SSH extension)
I tried to SSH to the shared V4 IP or the dedicated V6 IP, but both ways do NOT work

Is it a normal behavior? When I used fly ssh console, it still worked so I think normal SSH should work

If it’s normal behavior, is there any way to bypass allocating a dedicated V4 IP in order to SSH into my app?
An extra 2$/month for a dedicated V4 IP is somewhat not what I want

Hi @0xh8h

Shared IPv4 addresses can be used only for HTTP/HTTPS traffic.

fly ssh console sets up a WireGuard tunnel internally and connects to the running machine directly (bypassing fly-proxy) using its 6PN address.

You should be able to replicate this by configuring a WireGuard peer on your local machine (Private Networking · Fly Docs) and connecting to it using the 6PN address instead of <>.

You can use fly m list command to list the machines within the app with their 6PN addresses or use .internal domain name (Private Networking · Fly Docs) to reference the machine by name.

Thank you for your information

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.