Autoscale doesn't work

I have an app fly-foodbank-production-web with 2 processes: web and worker

When I try to execute the following command, nothing happens

flyctl autoscale standard min=2 -a fly-foodbank-production-web

and I see

What do I need to run to use autoscale?

1 Like

It would be good to get a better understanding how autoscale is supposed to work.

We’re also seeing an issue In the screenshot below, where it looks like one process is getting more than the others.

Ahhhh autoscaling doesn’t work for apps with multiple processes. Autoscale commands should definitely tell you this when you try to use them, sorry about that.

Autoscaling hasn’t worked all that well for Ruby apps, though, because it’s slow to respond and Ruby processes are slow to boot. Do you expect large traffic spikes or are you using it to minimize usage/bills?

1 Like

Ah ok. more minimising the bill, as the app have very spiky traffic (working hours).

@kurt does the autoscaling still not work with apps with multiple processes?

It’s not, no. We have a big autoscaling rework coming up in a few months and will have better options for autoscaling when it’s finished. The UX for this has been challenging and we want to make sure we get it right. Unfortunately, we started with a direction that didn’t manage additional complexity well, so “getting it right” almost means starting from scratch.


@kurt Any chance this has been revisited? It would be nice to get autoscaling working with processes, otherwise, we will need to refactor our app into many apps.


I’d like to know too if there’s been any progress on the new autoscaling system :slight_smile:

I’ve been looking into the machines API for building a CPU heavy scalable service but I’d need to manage the pool of machines myself, updates, rollbacks, etc.