App can't connect tp postgres from cli on my machine. However, it's working well from browser cli

Hello Everyone,

I am new at using The guide to deploying any project is simple and I like it. However, when I use the fly cli command fly launch from my terminal. In the stage of attaching the app to the Postgres database, there is an error. This is a pic of what I see:

However, when I use the fly cli in the browser(deploying my app from my GitHub repo), it deploys my project successfully.

I would appreciate your help

Are you on the latest flyctl version? If yes, run fly launch again and see if it’s able to attach the postgres? (don’t worry it won’t create a new one, it will try to attach the previously created one)

if that doesn’t work, you can delete the postgres instance that was created and try a new fly launch. It’s not clear why it failed but sometimes restarting the process can do the trick.

I checked the version. I use the latest version. I tried to rerun the fly launch command.I still get the same error

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.