After running flyctl builder destroy, I no longer have a builder

Following the instructions from some other posts, I ran the flyctl builder destroy <name> command when my remote builder ran out of space. Now, the builder is no longer listed in my organization’s list of apps or when using flyctl apps list. Furthermore, if I try to deploy my actual app, I am still receiving the following error:

==> Verifying app config
--> Verified app config
==> Building image
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.5 linux x86_64
[+] Building 1.1s (1/1) FINISHED                                                                                                                                                                                          
 => ERROR [internal] load remote build context                                                                                                                                                                       0.1s
 > [internal] load remote build context:
ERRO[0001] Can't add file (REDACTED)/.git/objects/14/e5ee5af74038f45c5c38e8fa75ff1a850ea419 to tar: io: read/write on closed pipe 
ERRO[0001] Can't close tar writer: io: read/write on closed pipe 
Error failed to fetch an image or build from source: error building: failed to solve with frontend dockerfile.v0: failed to read downloaded context: failed to load cache key: failed to prepare z7u1qdsw16rcbdebxtdbvwyfp: mkdir /var/lib/docker/overlay2/z7u1qdsw16rcbdebxtdbvwyfp: no space left on device

Is there a way to create a new builder and associate it with my app, or rebuild my “old” builder?

I don’t think you can manually create a new remote builder-- would you mind re-running that command with LOG_LEVEL=debug fly deploy --remote-only? This might help us better pinpoint what’s happening.

It looks like that did the trick. After showing this message a bunch:

DEBUG Remote builder unavailable, retrying in 59.898029ms (err: error during connect: Get "http://[fdaa:0:78f4:a7b:9f67:cc4:4935:2]:2375/_ping": connect tcp [fdaa:0:78f4:a7b:9f67:cc4:4935:2]:2375: connection was refused)

Now it seems to be building the image successfully.

Whatever you did worked – thanks!