v1 Deployment failed due to unhealthy allocations

Hi, I recently deployed a python app with Flyctl lauch and while monitoring deployment it failed.
I’ve attached the log screenshot and my fly.toml file. Please can someone help me ?

fly.toml file :

app = “ifreepikbot”
kill_signal = “SIGINT”
kill_timeout = 5
processes =

allowed_public_ports =
auto_rollback = true

http_checks =
internal_port = 8080
processes = [“app”]
protocol = “tcp”
script_checks =
hard_limit = 25
soft_limit = 20
type = “connections”

force_https = true
handlers = [“http”]
port = 80

handlers = [“tls”, “http”]
port = 443

grace_period = “1s”
interval = “15s”
restart_limit = 0
timeout = “2s”

Double check if the python process is listening on internal_port as defined in the app’s fly.toml (8080, in this case).

Check if VMs meet all the requirements (like env vars, files etc). More pointers here: Troubleshooting your Deployment · Fly Docs

1 Like

Exit code : 0

The screenshot indicates that nothing that you’re deploying is listening on port 8080 for TCP connections. Make sure the python process is binding its TCP listener to all interfaces (ideally :: for dual stack, or for ipv4) on 8080.

i am a newbie if you don’t mind, could you guide me on how to do this ?

Is your code public? If so, can you link it here? If not, what web server / tcp server are you running with Python?

Did you mean this one ? This one is a Telegram BOT

And also i’ve added EXPOSE 8080 to dockerfile and added PORT = “8080” to env in fly.toml file but nothing solved my issue

New Update : I’ve disabled heath checks for my app by referring to this post (Is there a way to disable health checks?) and now my app has deployed successfully and HEALTHY :partying_face:

Followed this to disable health checkups,

1 Like