Struggling to have prisma connect to fly postgres

Getting the following error

Error: Can't reach database server at `sjc.db-name-here.flycast`:`5432`
  Please make sure your database server is running at `sjc.db-name-here.flycast`:`5432

I’m using prisma, with a remix blue stack app.

Note: DATABASE_URL was set via the attach process. I tried to detach and re-attach with no luck. Same error.

Interestingly enough, when i use flyctl proxy and try to connect to it locally it works just fine. I can also use fly proxy and connect to the db using datagrip. More over, migrations work, its just not connecting on app start… very strange.

Note I also tried modifying the connection string to include the following:
and more

Any ideas?

There was a recent fix to the remix blues stack that addressed this issue.

1 Like

I should have just traced this code :man_facepalming:. Thanks for the fast response. This fixed it up for me!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.