Running maelstrom in windows

I have done all the prerequisites for installing maelstrom, and have downloaded the maelstrom-0.2.3. When I run the command for testing the file, I get no response. I guess the maelstrom binary is missing or not working. I am in a windows environment and am trying to run the command in powershell.

This is the command that I am running:
D:\Downloads\maelstrom-0.2.3\maelstrom-0.2.3> ./maelstrom test -w echo --bin ‘D:\Dev stuff\fly.io_dist-sys\maelstrom-echo\maelstorm-echo.exe’ --node-count 1 --time-limit 10 --log-stdout

Are you seeing error messages? If so, can you post those here.

I am not seeing any output at all. I might be trying to run maelstrom for the wrong location.

I also suspect the location of maelstrom-echo binary could be an issue. I ran go build and got a binary generated in the same folder as the code and put location to the same while running this.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.