Repeated failures to deploy due to VMs

I was able to successfully deploy my app using Github action workflows yesterday, but when I tried to make edits and push them through, those deployments failed. I deleted the app/free builder, workflow, dockerfile, fly.toml etc. and started everything over, resetting the FLY_API_Token.

Now the same app that deployed before is failing to deploy at every attempt. After successfully building and pushing several images, the error I get is: Error: failed to list VMs even after retries: unauthorized, and the deployment process exits.

Screenshot of my Actions monitor:

Copy of how my fly.toml references VMs:

[[vm]]
cpu_kind = “shared”
cpus = 1
memory_mb = 1024

I’m not sure what I could be doing wrong? The same setup worked just the other day. Thanks in advance for any help!

Update 1-6-24 1:30PM PST: I tried once again to deploy and the app finally deployed again, but when I tested pushing file changes to the running app it failed, giving the same error as above. Please help!