New account - app pending for over 12 hours

Hi everyone,

I have a Go http app in a private repo that I’m trying to deploy.

  1. Created new account
  2. Created a go app with launch in AUS. Following: Build, Deploy And Run A Go Application · Fly Docs
==> Validating app configuration
--> Validating app configuration done
Services
TCP 80/443 ⇢ 8080
Error failed building options: server returned a non-200 status code: 504

Checked fly status page but can’t see any errors, same with twitter, HN, etc.

  1. App shows as pending.
  2. Added credit card. No change.
  3. It was in pending for a while so changed to SJC. Still no change.
  4. Found buildpack docs and added path to main.go /cmd/myapp/, flyctl deploy to see if that updates it. Still pending.
  5. Destroyed and recreated and left it going overnight. It’s still pending now.
  6. Destroyed and recreated this morning, still pending.
  7. Try redeploy after remembering to add the path and got this:
==> Verifying app config
--> Verified app config
==> Building image
Error failed to fetch an image or build from source: failed building options: upstream service is unavailable
  1. Builder instance I see is Suspended. last log lines:
<snip - below repeats a bunch>
2022-09-03T18:30:50.077 app[3908051eb1e487] syd [info] time="2022-09-03T18:30:50.077244858Z" level=debug msg="checking docker activity"

2022-09-03T18:30:50.077 app[3908051eb1e487] syd [info] time="2022-09-03T18:30:50.077679578Z" level=debug msg="Calling GET /v1.41/containers/json?filters=%7B%22status%22%3A%7B%22running%22%3Atrue%7D%7D&limit=0"

2022-09-03T18:30:50.148 app[3908051eb1e487] syd [info] time="2022-09-03T18:30:50.148171457Z" level=info msg="Deadline reached without docker build"

2022-09-03T18:30:50.148 app[3908051eb1e487] syd [info] time="2022-09-03T18:30:50.148375677Z" level=info msg="shutting down"

I haven’t read all the docs but to me it looks like:

  1. there’s a builder “instance” that does a go build or docker build or something.
  2. there’s the app “instance” that run’s the binary/container.
  3. for some reason the builder is unable to build my app and the logs don’t show any sign of communication. Eventually the build job times out.
  4. maybe this is related to private repo?
  5. I’m on a NixOS machine should have outbound/etc.

Bit puzzled how to progress this.

Hi @karlskewes!

Since you mentioned that your builder app is coming up as suspended.

I suggest you try re-deploying but using the local docker build instead of the remote builder

fly deploy --local-only
1 Like

Also I noticed that you mentioned it was a private repository you were trying to deploy.

It’s likely that you are seeing the app as pending because the remote builder doesn’t support private Docker repositories unless you run the fly auth docker command.

Thank you!
Just got to try this out and it worked, the web service is now up. Happy days.

1 Like