Network unreachable in builder

I am trying to deploy my dockerfile-based app, but a (locally working) build doesn’t work, failing on the following step:

=> ERROR [dist 3/7] RUN wget -q -t3 'https://packages.doppler.com/public/cli/rsa.8004D9FF50437357.key' -O /etc/apk/keys/cli@doppler-8004D9FF50  0.6s
------
 > [dist 3/7] RUN wget -q -t3 'https://packages.doppler.com/public/cli/rsa.8004D9FF50437357.key' -O /etc/apk/keys/cli@doppler-8004D9FF50437357.rsa.pub &&     echo 'https://packages.doppler.com/public/cli/alpine/any-version/main' | tee -a /etc/apk/repositories &&     apk add doppler:
#8 0.488 wget: can't connect to remote host: Network unreachable
------
Error failed to fetch an image or build from source: error building: executor failed running [/bin/sh -c wget -q -t3 'https://packages.doppler.com/public/cli/rsa.8004D9FF50437357.key' -O /etc/apk/keys/cli@doppler-8004D9FF50437357.rsa.pub &&     echo 'https://packages.doppler.com/public/cli/alpine/any-version/main' | tee -a /etc/apk/repositories &&     apk add doppler]: exit code: 1

--local-only works, and destroying builder doesn’t help either. Anything I am missing?

Hey, is this still happening for you? If so, can you share your remote builder app name? This usually indicates a temporary issue between builders and external services like package managers.

Still happening on fly-builder-falling-wildflower-9409

Try running fly wireguard websockets enable and see if that helps?

Still the same error!

This should be working for you now. It turns out we had some Ipv6 networking trouble on the host where this VM lives. And packages.dopper.com has an Ipv6 IP address.

I can confirm that it works now.

1 Like