Laravel + Cloudflare: Port showing in URL

Hi there! I’ve been following various cloudflare +fly threads and I’ve decided to try it out, however I’m currently running into an issue where I’m using Cloudflare “flexible” option to avoid having to use an origin cert with my laravel app.

My issue now is if I disable the force_ssl option inside my fly.toml any of the urls that my laravel app is producing now show abc.xyz:80 instead of just the normal url, this does not happen when force_ssl is on.

If force_ssl is on however the app will infinitely redirect, which I’m not sure how to exactly fix either, any help would be greatly appreciated. Thanks!