Ghost Accelerator

How can i use this with normal http-node-proxy module instead of @fly/proxy
Github : GitHub - superfly/ghost-accelerator

Currently deploying fails due to this :

npm WARN deprecated core-js@2.5.7: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.
npm notice 
npm notice New patch version of npm available! 7.24.0 -> 7.24.1
npm notice Changelog: <https://github.com/npm/cli/releases/tag/v7.24.1>
npm notice Run `npm install -g npm@7.24.1` to update!
npm notice 
npm ERR! code 1
npm ERR! path /workspace/node_modules/integer
npm ERR! command failed
npm ERR! command sh -c node-gyp rebuild
npm ERR! make: Entering directory '/workspace/node_modules/integer/build'
npm ERR!   CXX(target) Release/obj.target/integer/src/integer.o
npm ERR! integer.target.mk:114: recipe for target 'Release/obj.target/integer/src/integer.o' failed
npm ERR! make: Leaving directory '/workspace/node_modules/integer/build'
npm ERR! gyp info it worked if it ends with ok
npm ERR! gyp info using node-gyp@7.1.2
npm ERR! gyp info using node@16.10.0 | linux | x64
npm ERR! gyp info find Python using Python version 3.6.9 found at "/usr/bin/python3"
npm ERR! gyp http GET https://nodejs.org/download/release/v16.10.0/node-v16.10.0-headers.tar.gz
npm ERR! gyp http 200 https://nodejs.org/download/release/v16.10.0/node-v16.10.0-headers.tar.gz
npm ERR! gyp http GET https://nodejs.org/download/release/v16.10.0/SHASUMS256.txt
npm ERR! gyp http 200 https://nodejs.org/download/release/v16.10.0/SHASUMS256.txt
npm ERR! (node:246) [DEP0150] DeprecationWarning: Setting process.config is deprecated. In the future the property will be read-only.
npm ERR! (Use `node --trace-deprecation ...` to show where the warning was created)
npm ERR! gyp info spawn /usr/bin/python3
npm ERR! gyp info spawn args [
npm ERR! gyp info spawn args   '/layers/heroku_nodejs-engine/nodejs/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py',
npm ERR! gyp info spawn args   'binding.gyp',
npm ERR! gyp info spawn args   '-f',
npm ERR! gyp info spawn args   'make',
npm ERR! gyp info spawn args   '-I',
npm ERR! gyp info spawn args   '/workspace/node_modules/integer/build/config.gypi',
npm ERR! gyp info spawn args   '-I',
npm ERR! gyp info spawn args   '/layers/heroku_nodejs-engine/nodejs/lib/node_modules/npm/node_modules/node-gyp/addon.gypi',
npm ERR! gyp info spawn args   '-I',
npm ERR! gyp info spawn args   '/home/heroku/.cache/node-gyp/16.10.0/include/node/common.gypi',
npm ERR! gyp info spawn args   '-Dlibrary=shared_library',
npm ERR! gyp info spawn args   '-Dvisibility=default',
npm ERR! gyp info spawn args   '-Dnode_root_dir=/home/heroku/.cache/node-gyp/16.10.0',
npm ERR! gyp info spawn args   '-Dnode_gyp_dir=/layers/heroku_nodejs-engine/nodejs/lib/node_modules/npm/node_modules/node-gyp',
npm ERR! gyp info spawn args   '-Dnode_lib_file=/home/heroku/.cache/node-gyp/16.10.0/<(target_arch)/node.lib',
npm ERR! gyp info spawn args   '-Dmodule_root_dir=/workspace/node_modules/integer',
npm ERR! gyp info spawn args   '-Dnode_engine=v8',
npm ERR! gyp info spawn args   '--depth=.',
npm ERR! gyp info spawn args   '--no-parallel',
npm ERR! gyp info spawn args   '--generator-output',
npm ERR! gyp info spawn args   'build',
npm ERR! gyp info spawn args   '-Goutput_dir=.'
npm ERR! gyp info spawn args ]
npm ERR! gyp info spawn make
npm ERR! gyp info spawn args [ 'BUILDTYPE=Release', '-C', 'build' ]
npm ERR! ../src/integer.cpp: In static member function 'static Result Integer::Cast(v8::Local<v8::String>, uint8_t)':
npm ERR! ../src/integer.cpp:329:33: error: no matching function for call to 'v8::String::Value::Value(v8::Local<v8::String>&)'
npm ERR!    v8::String::Value utf16(string);
npm ERR!                                  ^
npm ERR! In file included from /home/heroku/.cache/node-gyp/16.10.0/include/node/node.h:63:0,
npm ERR!                  from ../src/integer.hpp:3,
npm ERR!                  from ../src/integer.cpp:1:
npm ERR! /home/heroku/.cache/node-gyp/16.10.0/include/node/v8.h:3604:5: note: candidate: v8::String::Value::Value(v8::Isolate*, v8::Local<v8::Value>)
npm ERR!      Value(Isolate* isolate, Local<v8::Value> obj);
npm ERR!      ^~~~~
npm ERR! /home/heroku/.cache/node-gyp/16.10.0/include/node/v8.h:3604:5: note:   candidate expects 2 arguments, 1 provided
npm ERR! make: *** [Release/obj.target/integer/src/integer.o] Error 1
npm ERR! gyp ERR! build error 
npm ERR! gyp ERR! stack Error: `make` failed with exit code: 2
npm ERR! gyp ERR! stack     at ChildProcess.onExit (/layers/heroku_nodejs-engine/nodejs/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)
npm ERR! gyp ERR! stack     at ChildProcess.emit (node:events:390:28)
npm ERR! gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)
npm ERR! gyp ERR! System Linux 5.12.2
npm ERR! gyp ERR! command "/layers/heroku_nodejs-engine/nodejs/bin/node" "/layers/heroku_nodejs-engine/nodejs/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
npm ERR! gyp ERR! cwd /workspace/node_modules/integer
npm ERR! gyp ERR! node -v v16.10.0
npm ERR! gyp ERR! node-gyp -v v7.1.2
npm ERR! gyp ERR! not ok

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/heroku/.npm/_logs/2021-10-02T14_20_55_782Z-debug.log