Getting a random DNS_PROBE_FINISHED_NXDOMAIN error

We had a CNAME record in DigitalOcean to point to our demo environment and it worked perfectly fine. This evening we started getting a DNS_PROBE_FINISHED_NXDOMAIN error out of the blue. I’ve tried updating our DigitalOcean’s DNS to use the A & AAAA values, but still am seeing the same error.

We have done a lot of deploys over the past few days, could this be causing the issue? If not, what else could we check? Again our CNAME was working perfectly fine until this evening it randomly started showing DNS_PROBE_FINISHED_NXDOMAIN. If I go to the hostname it’s pointing at (the fly hostname) it works fine.

That sounds like a problem with DigitalOcean’s DNS service unfortunately. Especially if our own DNS entries ( work fine.

I’d recommend using another DNS provider. A summary search showed others have had the same issue, but there doesn’t seem to be a fix.

We like DNSimple for ourselves, if you’re looking for a recommendation.

1 Like

Hey there!

I ran into the same issue yesterday with a DNS setup on google domains for a fly app. The domain was accessible from Europe, US east but not US west.
This morning I realized that the fly UI didn’t ask me to set up the A record (only the AAAA). So I added an A record with the machine ipv4 address and now it seems okay.

By the way, I also had this issue with another app recently. The DNS was set on OVH. So maybe it’s not only a DNS service issue and something fly might want to check.