Fresh launch/deploy of Phoenix application fails with "failed to fetch an image or build from source"

Hi there,

I wanted to try out today for the first time for a new side-project I’m starting to work on.
For that, I’ve mainly followed the Phoenix Getting Started guide here (Getting Started · Fly Docs). The only difference is that I’ve used Phoenix 1.7.0 RC.0.
After I run fly launch and answer the “Would you like to deploy?” message with “yes”, I get the following output:

? Would you like to deploy now? Yes
==> Building image
Remote builder fly-builder-little-bird-5984 ready
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.12 linux x86_64
Sending build context to Docker daemon  138.3kB
[+] Building 815.5s (1/1) FINISHED
 => ERROR [internal] load remote build context                                                                                                                                                                                         815.5s
 > [internal] load remote build context:
Error failed to fetch an image or build from source: error building: error during connect: Post "http://[fdaa:0:f919:a7b:8a:912:e0d5:2]:2375/v1.41/build?buildargs=null&buildid=upload-request%3A7353d2f57c16f72f0f89977af8eddf030cae44d650bf5086a44dafabe9242c69&cachefrom=null&cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=&labels=null&memory=0&memswap=0&networkmode=&rm=0&shmsize=0&target=&ulimits=null&version=2": EOF

I’ve also tried to build locally (with --build-local) but unfortunately this also fails because I’m on a M1 MacBook.

The region I want to deploy to is fra (Frankfurt), but I’ve also tested with ams (Amsterdam) and it didn’t work either.

Any help is greatly appreciated.

P.S. I’ve also tried out now with a freshly generated Phoenix 1.6.15 app and it failed with the same error.