Flyctl list apps --accesstoken .... -json does not work unless logged in

When I logout and try

flyctl list apps --accesstoken … --json

It prompts Error No access token available. Please login with ‘flyctl auth login’ even though I supply the accesstoken in the command line.

Kindly advice.

This sounds like it might be similar to the problem I am running into: flyctl "No access token available" error when token is provided

It appears the current version of flyctl ignores the -t / -access-token command line options for many/most commands. The workaround I found is to instead specify the token in the FLY_ACCESS_TOKEN environment variable: