flyctl deploy: You hit a Fly API error with request ID...

Heya, in case you missed it, this should be resolved now


Hi! I an new to and just run the python tutorial in the document.
However, the problem as above seems not revolved.
Any advice is appreciated.

Maybe your problem will be similar to this:
[URGENT] Contact Lost with instance - Questions / Help -

@Cadulogy Thanks for your advice.
I take a look in this reply and check the
flyctl logs -a MY_FLY-builder
It shows “Deadline reached without docker build”

I think the problem is like the reply as ‘LuxuryMode’
since my deploy error also shows

2022-10-09T06:53:04.000 [info]     return _bootstrap._gcd_import(name[level:], package, level)
2022-10-09T06:53:04.000 [info]   File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
2022-10-09T06:53:04.000 [info]   File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
2022-10-09T06:53:04.000 [info]   File "<frozen importlib._bootstrap>", line 1004, in _find_and_load_unlocked
2022-10-09T06:53:04.000 [info] ModuleNotFoundError: No module named 'server'
2022-10-09T06:53:04.000 [info] [2022-10-09 06:53:04 +0000] [538] [INFO] Worker exiting (pid: 538)
2022-10-09T06:53:04.000 [info] [2022-10-09 06:53:04 +0000] [520] [INFO] Shutting down: Master
2022-10-09T06:53:04.000 [info] [2022-10-09 06:53:04 +0000] [520] [INFO] Reason: Worker failed to boot.
2022-10-09T06:53:05.000 [info] Starting clean up.

I am still having this same issue. I managed to deploy the app once by spamming flyctl launch and flyctl deploy until it finally succeeded.

After that I unfortunately accidentally removed the project and now I have been spamming those commands over 10 times and I am still unable to deploy the project…

Oh wait, just now it finally succeeded again. Only thing that I did differently was to open my project in the dashboard and open the monitoring tab while deploying.


flyctl version update
flyctl agent restart


fly deploy

Since 2-3 hours, I am seeing the same error in FRA & AMS (have not tried other regions yet):

image size: 221 MB
==> Creating release
Error You hit a Fly API error with request ID: 01GFNFZ6HN3Z750PDVRA5MEJTD-fra

flyctl upgrade, agent restart, launch/deploy did not help. Neither fly deploy --verbose, nor log provides any additional info.

1 Like

Same as @hb9cwp for FRA., since this morning (French time).
Worked fine before that.

Maybe it’s related to the last flyctl update. Before updating the agent, everything worked fine.

1 Like

I have the same issues unfortunately. I am currently using a hobby plan, I was wondering if it is something to do with the image size.

Image size: 699 MB
==> Creating release
Error You hit a Fly API error with request ID: 01GFNM09WD4J5544X9P6E367XK-fra

@c3y I am also on the free plan, as my image is 221 MB, I had doubled RAM from 256 to 512 MB temporarily, but that did not help.

Also, there are reports about connectivity issues within the private WireGuard networks (6PN) and SSH. However, this appears to be ok in my case:

$ fly version
flyctl v0.0.414 linux/amd64 Commit: 463a8297 BuildDate: 2022-10-17T21:24:47Z
$ fly doctor
Testing authentication token... PASSED
Testing flyctl agent... PASSED
Testing local Docker instance... Nope
Pinging WireGuard gateway (give us a sec)... PASSED

App specific checks for vauXXX55:
vault5 app has not been deployed yet. Deploy using `flyctl deploy`.

However, it is strange that the error message always shows the same -fra suffix regardless if I try to deploy in FRA, AMS, LAX, or SIN?

1 Like

It finally works for me. I just tried again without any changes on my computer.

1 Like


I agree, no matter which region you try, the error message always comes up with the -fra suffix.

However for me as well lax region finally worked. Thanks for the information you are also in free tier @hb9cwp. I was suspicious whether I was going over limits somehow.

I read that free tier offers 256MB ram, however we can still scale it in the instance. Do you have any idea about the limitations? Any information would really help. Thanks!

hi everyone, following up here since we resolved the issue preventing deploys:

This should be resolved but please feel free to let us know if you’re still having deploy problems

This problem still happening here:

==> Verifying app config
--> Verified app config
==> Building image
WARN Failed to start remote builder heartbeat: You hit a Fly API error with request ID: 01GG9009YGESKNK2J76YCZCRMX-gru
Error failed to fetch an image or build from source: error connecting to docker: You hit a Fly API error with request ID: 01GG9012GV26Z4Z4M39ECNRR1Y-gru

I just found your error, and might have fixed it. Can you give it another try?

Thanks for the help Kurt!

Now I’m having another problem after release is created - a message of Failed Deplyoment:

 1 desired, 1 placed, 0 healthy, 1 unhealthy
--> v1 failed - Failed due to unhealthy allocations - no stable job version to auto revert to and deploying as v2 

--> Troubleshooting guide at
Error abort

I’m unable to deploy one app on GRU since yesterday, not sure why, just this one app, others I can deploy without issue.

Error You hit a Fly API error with request ID: 01GGA43NCYK6Z9SD3VK0TS2RP9-gru

I am also receiving this error during launch and deploy.

==> Creating release
Error You hit a Fly API error with request ID: 01GGAAZTCDMDEN35GWDFXN59XV-sin

I am traveling in SE Asia, and was using the Singapore region. I updated it to Denver, but it is still failing. Interestingly, the reqestuest ID still has the sin suffix:

==> Creating release
Error You hit a Fly API error with request ID: 01GGACW5ZNM1NJXST26JPZ4RAE-sin

The Fly launch/deploy service was temporarily down due to running out of IPv4 address space.

I’m also receiving this error

fly deploy -a [redacted]
==> Verifying app config
--> Verified app config
==> Building image
Remote builder [redacted] ready
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.12 linux x86_64
[+] Building 0.0s (0/1)                                                                          
[+] Building 0.9s (15/15) FINISHED                                                               
 => CACHED [internal] load remote build context                                             0.0s
 => CACHED copy /context /                                                                  0.0s
 => [internal] load metadata for                          0.8s
 => [builder 1/8] FROM  0.0s
 => CACHED [builder 2/8] RUN apt-get update; apt install -y curl                            0.0s
 => CACHED [builder 3/8] RUN curl | bash                               0.0s
 => CACHED [builder 4/8] RUN volta install node@18.0.0                                      0.0s
 => CACHED [builder 5/8] RUN mkdir /app                                                     0.0s
 => CACHED [builder 6/8] WORKDIR /app                                                       0.0s
 => CACHED [builder 7/8] COPY . .                                                           0.0s
 => CACHED [builder 8/8] RUN npm install                                                    0.0s
 => CACHED [stage-1 2/4] COPY --from=builder /root/.volta /root/.volta                      0.0s
 => CACHED [stage-1 3/4] COPY --from=builder /app /app                                      0.0s
 => CACHED [stage-1 4/4] WORKDIR /app                                                       0.0s
 => exporting to image                                                                      0.0s
 => => exporting layers                                                                     0.0s
 => => writing image sha256:ae7442bf6424b1623b9fd26db09c90485750734724425e01fbe1bcad96ba8c  0.0s
 => => naming to[redacted]:deployment-01GGADV11MH5Q3G6Y0JEW  0.0s
--> Building image done
==> Pushing image to fly
The push refers to repository [[redacted]]
5f70bf18a086: Layer already exists 
c7af6d6da583: Layer already exists 
545421f00d1e: Layer already exists 
d9d07d703dd5: Layer already exists 
deployment-01GGADV11MH5Q3G6Y0JEWDJ17B: digest: sha256:b1762980fbb0660f8b8c0c7322e2b3a3255ff2d4a159ac52823005cf19c890e2 size: 1159
--> Pushing image done
image size: 575 MB
==> Creating release
Error You hit a Fly API error with request ID: 01GGADV4MPB5Q3WW18GGJBHEDE-lhr
1 Like

~10-13hr ago we right at the limit on our ipv4 address space, which resulted in the intermittent errors dearshrewdwit, jteppinette, crossworth saw. That issue has been fixed. Sorry for the trouble!

1 Like