fly won't allow connections to an app called "lp"?

I’m running into a strange issue where I can’t connect to my app, and it seems to just be a matter of an evil name. When I deploy my docker app with the app name of lp, I can’t connect to it:

$ curl
curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to
  Name     = lp          
  Owner    = personal    
  Version  = 0           
  Status   = running     
  Hostname =  

Deployment Status
  ID          = 608bbab5-cb15-e348-c90a-48bfe71fd5a6         
  Version     = v0                                           
  Status      = successful                                   
  Description = Deployment completed successfully            
  Instances   = 1 desired, 1 placed, 1 healthy, 0 unhealthy  

4a92ff23 0       ewr    run     running 1 total, 1 passing 0        41s ago 

If I use the exact same deploy script to push the same image with a different name, everything works as expected.

I’ve tried destroying the lp app and redeploying it, but it always fails as long as I use that name. But another name like lp7 works fine. I thought maybe it was two-letter names, but I successfully pushed an app called zx and that worked fine.

I’m leaving my lp instance up in case Fly folks want to investigate, but it’s just a throwaway instance, so feel free to kill it or send whatever requests to it that you want.

Destroying it and recreating might be the problem. Each app gets its own IP, so DNS might be cached for you locally. Does this work for you?

curl --resolve

Ah, that explains it. I’m able to connect that way. Sorry for the noise!

No worries, we pretty much love all posts in this forum and you have a great avatar.