fly migrate-to-v2 - postgres edition

It finally died 10-15 mins ago. I am guessing that it rolled back the creation and the one that is left is the one I cloned.

Appreciate your help.

PostGIS is included in the image, but we do not enable the extension automatically. You can do this by running:


1 Like

@danwetherald you’re all set. Sorry about that.

1 Like

Thank you so much for the help!

1 Like


BTW this info should be in your docs :wink:

1 Like

@DAlperin - Getting an error trying to upgrade a pretty old pg app.

Error: 404: 404 page not found

app: rotator-api-pg

Thanks in advance!

Yeah it seems like you’ve identified a weird bug where the auto image update isn’t working. I’m gonna look into that tomorrow.

1 Like

Thank you. Let me know if you need anything from me.

@danwetherald I fixed a bug in the migrator that I think was causing the problems you were having. The fix is out in the latest flyctl version.

Looks like 0.530 isnt latest yet.

@DAlperin We are still getting the same error as before when trying to upgrade an old pg deployment on version0.532

@DAlperin I am still not able to migrate old PG apps to v2, any ideas?

I am still getting Error: 404: 404 page not found


I can also not restart these pg apps either:

fly apps restart rotator-api-pg                                                                                                                                                                    
Error: postgres apps should use `fly pg restart` instead

fly pg restart                                                                                                                                                                                       
Error: command is not compatible with this image

running fly version 0.549

1 Like

Hello, getting the following error when running the fly migrate-to-v2 command for my Postgres app:

 2 desired, 1 placed, 0 healthy, 1 unhealthy
--> v1 failed - Failed due to unhealthy allocations and deploying as v2 

--> Troubleshooting guide at
failed while migrating: abort
==> (!) An error has occurred. Attempting to rollback changes...
>  Disabling readonly
failed while rolling back application: can't get role for fdaa:0:476d:a7b:5adc:1:6276:2: Get "http://fdaa:0:476d:a7b:5adc:1:6276:2:5500/commands/admin/role": connect tcp [fdaa:0:476d:a7b:5adc:1:6276:2]:5500: operation timed out
Error: abort

Then I tried a couple more times, but I kept getting:

==> Migrating db to the V2 platform
>  Upgrading postgres image
>  Setting postgres primary to readonly
failed while migrating: 404: 404 page not found

==> (!) An error has occurred. Attempting to rollback changes...
>  Disabling readonly
failed while rolling back application: 404: 404 page not found

Error: 404: 404 page not found

Running fly v0.0.549

I am still stuck with a postgres app running in v1 with a VM that is stuck in a bad state, I am not able to re-deploy, restart, or migrate. At the moment I at least have been able to scale to 2 VMs so that its at least working but it would be nice to get migrated to v2 and get back to a 100% healthy state.

Any ideas @DAlperin ?

@stakindotcom Could you try running fly agent restart and try again?


Can you confirm everything looks good on your end?

@shaun nope, nothing has changed, haven’t been directed to try anything new. Everything is still the same on my end.

@danwetherald What app are you having trouble with?

@shaun rotator-api-pg

What issues are you experiencing? It looks healthy on my end.