Fly deploy stuck at 'Configuring firecracker' ...

Hello again…

after a first ‘fly launch’, which is starting the machine but failing with the error that the env variable OpenAI_API_Key was not found,
I set the secret in the browser app and restart via ‘fly deploy’,
which always gets stuck at ‘configuring firecracker’.

only if I delete the machine and launch again,
it is at running and breaking with errors.

I tried:
setting fly secrets :x:
putting the secret as [env] into the fly.toml (not recommended, I know) :x:
redeploying machines :x:
re-launching the whole app and settings :x:
following the instructions on fly io docs about providing an env for the build process: :x:

RUN --mount=type=secret,id=OPENAI_API_KEY
OPENAI_API_KEY=“$(cat /run/secrets/OPENAI_API_KEY)”

and then

fly deploy
–build-secret OPENAI_API_KEY=XXXXXXXXXXXXXX

any ideas appreciated, thanx

Re-STARTING the machines did the trick:

$ fly machine stop (kill didn’t work. Error message: failed_precondition: machine not in known state for signaling, stopped)
$ fly machine start

(edit: in my first draft of the init post above I wrote that I tried to restart the machines. What I actually meant that I was re-deploying and by this kind of restarting.)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.