Failed to proxy HTTP request on Fresh Deploy

I’m having an issue where when I created a fresh version of my app with fly launch I get the following error on the app’s terminal:

Failed to proxy HTTP request (error: no known healthy instances found for route tcp/443. (hint: is your app shutdown? is there an ongoing deployment with a volume or using the ‘immediate’ strategy? if not, this could be a delayed state issue)). Retrying in 1000 ms (attempt 90)

I have successfully deployed this app before and I cannot figure out what I am doing wrong.

Here’s my fly.toml file:

# fly.toml file generated for rpchat on 2023-04-08T17:46:57-04:00

app = "rpchat"
kill_signal = "SIGINT"
kill_timeout = 5
mounts = []
primary_region = "bos"
processes = []

  image = "ryanscottgibbs/rpchat:latest"


  internal_port = 8080
  processes = ["app"]
  protocol = "tcp"
    hard_limit = 25
    soft_limit = 20
    type = "connections"

    force_https = true
    handlers = ["http"]
    port = 80

    handlers = ["tls", "http"]
    port = 443

I’ve checked my secrets and they’re all listed. I’ve used ssh to get to the app and can connect just fine. All my health checks are green. I’m not sure what I’m missing.

Hey there! Your app seems to be working just fine from what I can tell. Sometimes you’ll see that message right when you deploy if you try to reach your app before the machine finishes starting up. Are you still having issues?

I was still having this issue, but seeing you say it was working, I tried opening it in an incognito window and it worked. So I closed my browser and re-opened and tried to connect and was successfully able to get it working.

Not sure what the issue was, but thank you for the help.

This sometimes happens when you create an app, then deleted it, then create a new app with the same name.

Browsers like to cache DNS, so it’s like it was connecting you to the wrong IP. Our proxy would have still tried to route the old IP to your old app, which had the same name, then discovered there were no instances.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.