Failed Fly deploy

Hi everyone,

I am pretty sure there is an issue somewhere but I just can’t pin point.
I forked an open source then started it on my local machine which worked fine.

However, when I tried to deploy, it keeps failing.
When I ran “Fly launch”

I set everything to yes except No to dockerfile and .dockerignore overrides. I wonder if the failure is coming from there.

➜  forem git:(main) ✗ fly deploy   
==> Verifying app config
--> Verified app config
==> Building image
Remote builder fly-builder-snowy-fire-1167 ready
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.12 linux x86_64
[+] Building 1291.0s (0/1)                                                                                       
[+] Building 268.0s (24/24) FINISHED                                                                             
 => [internal] load remote build context                                                                    0.0s
 => copy /context /                                                                                         5.2s
 => [internal] load metadata for                                                   2.9s
 => [base 1/1] FROM  0.3s
 => => resolve  0.3s
 => CACHED [builder  1/15] RUN curl -sL -o /etc/yum.repos.d/yarn.repo  0.0s
 => CACHED [builder  2/15] RUN gem install -N bundler:"2.2.22"                                              0.0s
 => CACHED [builder  3/15] RUN mkdir -p /opt/apps/forem && chown "1000":"1000" "/opt/apps/forem" &&     gr  0.0s
 => CACHED [builder  4/15] RUN wget"v0.6.1"/docker  0.0s
 => CACHED [builder  5/15] WORKDIR /opt/apps/forem                                                          0.0s
 => CACHED [builder  6/15] COPY ./.ruby-version /opt/apps/forem/                                            0.0s
 => CACHED [builder  7/15] COPY ./Gemfile ./Gemfile.lock /opt/apps/forem/                                   0.0s
 => CACHED [builder  8/15] COPY ./vendor/cache /opt/apps/forem/vendor/cache                                 0.0s
 => CACHED [builder  9/15] RUN bundle config --local build.sassc --disable-march-tune-native &&     BUNDLE  0.0s
 => [builder 10/15] COPY . /opt/apps/forem                                                                  2.9s
 => [builder 11/15] RUN mkdir -p "/opt/apps/forem"/public/{assets,images,packs,podcasts,uploads}            0.4s
 => [builder 12/15] RUN NODE_ENV=production yarn install                                                   64.8s
 => [builder 13/15] RUN RAILS_ENV=production NODE_ENV=production bundle exec rake assets:precompile       127.4s
 => [builder 14/15] RUN echo $(date -u +'%Y-%m-%dT%H:%M:%SZ') >> "/opt/apps/forem"/FOREM_BUILD_DATE &&      0.4s 
 => [builder 15/15] RUN rm -rf node_modules vendor/assets spec                                              2.5s 
 => [development 1/4] COPY --chown=forem:forem ./spec /opt/apps/forem/spec                                  0.2s 
 => [development 2/4] COPY --from=builder /usr/local/bin/dockerize /usr/local/bin/dockerize                 0.0s 
 => [development 3/4] RUN chown "forem":"forem" -R "/opt/apps/forem"                                       19.5s 
 => [development 4/4] RUN bundle config --local build.sassc --disable-march-tune-native &&     bundle con  18.3s 
 => exporting to image                                                                                     14.4s 
 => => exporting layers                                                                                    14.4s 
 => => writing image sha256:d0e484433c9d3c241c7db191a20d4c4149f5fcf73ac72eb0f3a4379fe901e8a3                0.0s
 => => naming to                             0.0s
--> Building image done
==> Pushing image to fly
The push refers to repository []
318e01482c45: Pushed 
e77409245749: Pushed 
7eb4282b2a62: Pushed 
309f9f296cf4: Pushed 
c34b96fff75d: Pushed 
32c54bc76ab2: Pushed 
beee78b186a3: Pushed 
9b9ff77c94d6: Pushing [==================================================>]  730.4MB/730.4MB
5befe39f57b8: Pushed 
05832552ea87: Retrying in 10 seconds 
5d9fbde5e4b5: Pushed 
75b09eb5235e: Pushed 
43d8e69a47cc: Pushed 
a6d886c3bf79: Pushed 
5f70bf18a086: Layer already exists 
dc30eeedd645: Pushed 
30e09d1b577b: Pushed 
70c61564739e: Pushed 
9752fbf8d85f: Pushed 
6d45972a8fa3: Pushed 
3cd4ec6811b7: Pushed 
80f516d0e5a8: Pushed 
Error failed to fetch an image or build from source: error rendering push status stream: write tcp [2605:4c40:33:84a3:0:5b67:f71b:1]:47210->[2a09:8280:1:f132:9b03:c39f:b404:f5d2]:443: write: broken pipe

Hi @knhchris , Looks like a network issue to the registry. There have been reports of connectivity issues to the registry.

Thanks, I seem to have solid internet connection so I am not too sure what might be the issue.

Not with your Internet connection @knhchris . The network issue seems to be between the remote docker builder (fly-builder-snowy-fire-1167) and the fly docker registry(

Ahh I see!

Sorry for the misunderstanding as I am relatively new to this space.

Is there anything I should check in particular to get it working?
e.g. should I check the dockerfile config?

ok resolved!

Basically I just had to force the deploy with existing dockerfile by using the command:

fly deploy --dockerfile Dockerfile 

Good that it got resolved after redeploying.