Deployments using remote builder failing

Hi there,

My deployments have just started failing in the last few hours. In the dashboard, my remote builder seems to be suspended, and is generating the following output in the logs every second:

2022-10-12T20:19:40.570 app[9185909c137d83] lhr [info] time="2022-10-12T20:19:40.568979322Z" level=debug msg="checking docker activity"
2022-10-12T20:19:40.570 app[9185909c137d83] lhr [info] time="2022-10-12T20:19:40.569357062Z" level=debug msg="Calling GET /v1.41/containers/json?filters=%7B%22status%22%3A%7B%22running%22%3Atrue%7D%7D&limit=0"

I have tried deleting and re-deploying, but the new builders have the same behaviour.

In my terminal, when I run fly deploy on a new builder I get the following output:

==> Verifying app config
--> Verified app config
==> Building image
Remote builder fly-builder-summer-sea-3306 ready
==> Creating build context
--> Creating build context done
==> Building image with Docker
--> docker host: 20.10.12 linux x86_64
[+] Building 804.7s (0/1)
 => [internal] load remote build context                                 804.7s
ERRO[0819] Can't add file [redacted]
[+] Building 815.8s (1/1) FINISHED
 => ERROR [internal] load remote build context                           815.8s
 > [internal] load remote build context:
Error failed to fetch an image or build from source: error building: error during connect: Post "http://[fdaa:0:4c82:a7b:bbfa:eef6:b60a:2]:2375/v1.41/build?buildargs=null&buildid=upload-request%3A11ddc2ed19dac0d307f7e7951684fff08fa41fed2220050aea2f7888619c7af7&cachefrom=null&cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=&labels=null&memory=0&memswap=0&networkmode=&rm=0&shmsize=0&target=&ulimits=null&version=2": write unix -> [redacted]/.fly/fly-agent.sock: write: broken pipe

Any help gratefully received!

See if enabling websocket for flyctl’s userspace wireguard works: Failed to fetch an image or build from source: error building: unexpected EOF - #2 by kurt

If not, there’s always the local deploy: fly deploy getting error load metadata for - #2 by ignoramous

Thanks @ignoramous.

The issue seems to have resolved itself now. I think it was probably due to trying to deploy while on a slow public WiFi network.

1 Like