Complete broken site

Not sure of the topic, but my site had been working and woke up this morning to a grey screen and errors about an api auth errors. The site is hosted in 4 regions. One of the regions is stuck in a different version then the other three regions.

I’ve tried to scale the memory in hopes of restarting something. I tried to remove the “bad” region with no luck and no errors. After a day of trying everything I had to setup a new application. After which eveything is working again.

But now I’m in the process of setting up new certificates so I can switch to the new site.

Fortunately, this is a bit of a playground site for me, I have another hosted on and a bit nervous that I might wake up to another “broken” site. Any help in understanding what is even breaking here so I can fix on my own next time as switching to a new site seems a bit excessive. thanks in advance.

The wx4me app is probably stuck an impossible setup. Like, if you do this:

fly scale count 4 --max-per-region=1

Then remove a region, it will hang. Because it can’t run 4 VMs in three regions with that config. So it will keep the old ones around until it figures out what to do.

The api auth errors don’t sound like something we’d generate, though. Is it possible you’re hitting an upstream API and getting rate limited or something?

Thanks for the suggestion. The errors were from the server logs so not much help in figuring out what was happening. I just ended up deleting the app and moving to the newly created app. Hopefully an anomaly.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.