Can't connect to Redis + deploy never finishes (LHR region)

Any problems in London currently?

I canceled the deploy after 15 minutes, it was stuck here:

Run flyctl deploy --remote-only
==> Verifying app config
--> Verified app config
==> Building image
Waiting for remote builder fly-builder-lively-pond-5355...
Remote builder fly-builder-lively-pond-5355 ready
==> Building image with Buildpacks
--> docker host: 20.10.12 linux x86_64
20: Pulling from heroku/buildpacks
Digest: sha256:c8b97ad65a32ecb5fe96d6dd5a4d63f847c74eb7cd1d7dc6f01a65d313f05ab5
Status: Image is up to date for heroku/buildpacks:20
20-cnb: Pulling from heroku/heroku
Digest: sha256:26ec15fdf56a83cf90ecbf0efdb0bd41a446b5051d2d65163b1a22d5554f7299
Status: Image is up to date for heroku/heroku:20-cnb
heroku/ruby     0.0.0
heroku/procfile 2.0.0
Restoring metadata for "heroku/ruby:shim" from cache
Restoring data for "heroku/ruby:shim" from cache
-----> Installing bundler 2.3.10
-----> Removing BUNDLED WITH version in the Gemfile.lock
-----> Compiling Ruby/Rack
Error: The operation was canceled.

(I’m deploying from GitHub Actions using flyctl: fly/action.yml at 2f13862dc7c1113a6ab7a61e5785285696030836 · dentarg/fly · GitHub)

Tried deploying again and it worked. Still can’t connect to Redis, getting “Connection reset by peer”. I have my timeout set to 30 seconds (and 10 retries). Status - Failures to connect to managed Upstash Redis databases I guess

Any updates here? I’m having the same problem